고급 Python

트러블 슈팅

pip 업그레이드 후 Syntax 오류

  File "/usr/lib/python2.7/site-packages/pip/_internal/cli/main.py", line 60
    sys.stderr.write(f"ERROR: {exc}")
                                   ^
SyntaxError: invalid syntax

 최신 버전으로 업그레이드 후 Python 2.x 문법을 사용하는 패키지를 설치 할 시 나타나는 오류이며, 2.x를 지원하는 마지막 버전인 20.3.4로 업그레이드해야 한다.

pip install --upgrade pip==20.3.4

댓글

댓글 본문
graphittie 자세히 보기