Database2 - Lowdb

설치 - Node.js

수업소개

Node.js 환경에서 lowdb를 설치하는 방법을 소개합니다. 
 

 

 

강의

 

 

 

소스코드

main.js

const low = require('lowdb')
const FileSync = require('lowdb/adapters/FileSync')
const adapter = new FileSync('db.json')
const db = low(adapter)

 

댓글

댓글 본문
  1. hyeseong
    lowdb 버전이 바뀌어서 그대로 따라하면 ERR_REQUIRE_ESM 에러가 발생했습니다.
    대충 찾아보니 pure ESM package 관련 에러인 것 같은데 더 공부가 필요한 부분인듯 합니다.

    lowdb github를 보고 새 버전대로 따라해도 어찌 당장 에러가 해결되지 않아서
    npm install -s lowdb@1.0.0 명령어를 사용 해 이전 버전의 lowdb를 설치하여 일단 따라합니다.
    혹시 비슷한 어려움을 겪으 시는 분들에게 도움이 될까 하여 남깁니다.

    혹은 새 버전에서 같은 내용으로 따라하는 방법을 아시는 분이 계신다면 알려주시면 정말 감사하겠습니다 ㅠㅠ
  2. labis98
    20210824 good!!!
  3. 김윤석
    21.04.27
  4. jeisyoon
    2021.03.27 Nodejs Lowdb - Start
  5. chimhyangmoo
    21.03.08
  6. 생활둘기
    2021 2 15
  7. Yong Hyun Lee
    완료 200920
  8. 착한얼굴에그러치모탄태도
    감사합니다
  9. 쑤우
    수강완료. 감사합니다~
  10. Amousk
    설치 완료!
  11. supernet
    완료!!
  12. 상구미
    Global 옵션은 저도 유명한 프레임워크들만 사용해요 express, react 등등..
    대화보기
    • 삼고잉
      일단 설치 완료
    • Hyung Jun Choi
      npm을 이용해서 설치해도 mudules폴더가 안생기네요..ㅠ
      ---------------------------------------------------------------------------------
      추가.
      npm을 이용해 모듈을 설치할 때, -s 옵션을 줘서 node_modules폴더가 생기도록 하시는 것이 좋습니다.
      저는 괜히 -g 옵션을 줘서 글로벌로 설치하려고 했는데, 글로벌 설치에 관한 오류가 많아서 이리저리 삽질하느라 고생만 했네요.
      결국 웬만하면 글로벌 설치는 포기하고 로컬설치를 하는 것이 좋습니다.
    • Robert Eric
      editor는 vs code 쓰고 계신 것 같네요.ㅎㅎ 저도 vs code 씁니다
      대화보기
      • 그린이
        혹시 무슨 에디터를 이용하신건가요??

        그리고 sublime text3를 에디터로, 일반 cmd창을 터미널로 이용해서 사용할 수 있나요?
      • hallo88
        굉장히 흥미로운 주제네요. 관계형 데이터베이스만 사용하다가 좋은 내용 알아 갑니다.
      graphittie 자세히 보기